Installation

Preset can be used by running npx use-preset. Running it this way will ensure that it is always up-to-date when you use it.

However, if you are using it frequently, you may want to install it globally:

# Yarn
yarn global add use-preset

# NPM
npm i -g use-preset

Requirements

Preset requires the current long-term-support version of Node and Git. Since presets are cloned locally, git must be accessible from the PATH environment variable.

Usage

A preset can be applied by providing its URL, GitHub handle or path as the first argument.

npx use-preset your-github-username/your-preset

You can change the directory of installation by using the --in flag. This may be useful for presets that are actually scaffolding projects.

npx use-preset tailwindcss --in my-app